Gutenberg update (WordPress 5.0)

You might already heard about WordPress 5.0 new release which will include new editor called Gutenberg. We are not going to explain here what are the new features as you will find plenty of articles in web.

Some important information you should know regarding to WooCommerce and WooCommerce Bookstore plugin.

Gutenberg and WooCommerce Products

According to WooCommerce Gutenberg is not fully compatible with WooCommerce Products and will take some time in order to implement it. As a result WooCommerce Book type, which WooCommerce Bookstore uses, is not compatible as well.

Gutenberg only for Pages and Posts

For the current period Gutenberg will only work for Pages and Posts. Before you upgrade to WordPress 5.0:

  • Take a full backup of your installation and make sure you are able to restore it
  • Theme compatibility – make sure your theme is compatible with WordPress 5.0 and WooCommerce latest version. If you don’t find that information contact with author
  • Plugin compatibility – make sure that all installed plugins are compatible with WordPress 5.0 and WooCommerce latest version.
  • Gutenberg Incompatibility – if after upgrade you find issues with Gutenberg you may deactivate it by using this plugin¬†

WooCommerce Bookstore and WooCommerce 3.5.x

Our plugin is compatible with WooCommerce 3.5 and WordPress 5.0 since version 3.5. Please for more information please refer to plugin’s changelog.